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Overview 
Batch Printing is a plotting tool included in MicroStation.  It can be used to print multiple sheets from 
multiple MicroStation

 

 files with one print request.  The Office of Design produces only PDF files with 
the Batch Print tool, for two reasons: 

1.  Non-changing PDF’s eliminate the differences between hard copies and print files. 
2.  Printing only to PDF files eliminates the need to produce and maintain a list of special printer 
settings which would be required if printing directly to the large variety of available printers. 

 
The MicroStation

 
 files can be printed to individual PDFs or to a multipage PDF.  

Print Border (Plot Shape) 
 

Print Borders, (or Plot Shapes, as they are usually called), must be present in the file prior to using 
the MicroStation Batch Print procedure, as used by the Office of Design and herein described.   Plot 
Shapes have specific element attributes that are used by the MicroStation Batch Print process to 
locate and print the correct sheets.  For additional information on Plot Shapes, see instruction file 
21A-80 . 
 

Plot Identification 
 
The plot identification information is included in PDF and hard copy prints.  The plot identification 
includes the “Date, Login ID, and File Name and Location”, and is displayed directly below the lower 
left corner of the sheet, as shown by the arrows below.   
 

 
 
Troubleshooting Plot ID problems:   
 If the plot identification information does not convert to the proper information,  

AND if the CBIS pen table was correctly selected,  
Then your MicroStation

 

 “.upf” file (User Preference File), has probably become corrupt and 
should be deleted. 

NOTE:  After deleting the upf file, a new upf will be automatically created when MicroStation

C:\Documents and Settings\username\usernameXM.upf  

 
is restarted.  The upf file is located as follows:   

  
If the plot identification information is not present, the “border” reference file level 
“DsnShtPlotIdentification” is not turned on in the sheet file.  (The original plot ID data must be 
displayed, (visible), to enable the Design.tbl Pen Table to locate it and convert it to the proper 
information.) 
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Launching Batch Print 
The MicroStation Batch Print 
procedure is accessed from 
within MicroStation

as shown at the right. 

, from the 
pull-down File > Batch Print,  

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

This will produce the Batch Print 
dialog, as shown at the right.  
Double-click any of the 
highlighted items to produce an 
options dialog for that item.   
 
By default, the Batch Print 
settings have been set to search 
the files for active “plot-shapes” 
on the level called 
dsnShtPlotShapeBatchPrint, and 
to produce 11x17 gray-scale 
prints.  See the details of the 
various options below.    
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Batch Print Settings 
 

PDF Printer Specifications 
 

Double-clicking the Printer item in the Batch Print 
dialog, shown above, will produce the Select Printer 
Specification dialog with the options shown at the 
right.  Several paper sizes are available with three 
color choices for most paper sizes, including: 

1. _bw_ option to produce black and white and 
gray-scale prints   

2.  _clr_as-is_ option to produce a print with the 
colors shown on the screen, as in “What You 
See Is What You Get”, (WYSIWYG) 

3. _clr_over-rides_ option to return some 
elements as colored but many colored elements are converted to black for printing.   

 
See the color tables below for examples of what the above listed choices will produce.  

 
          _bw_        _clr_as-is_       _clr_over-rides_   
 

         
 

Print Area Specifications 
 

Double-clicking the Print Area item in the Batch 
Print dialog will produce the Select Print Area 
Specification dialog, as shown at the right. 
 
Active+Reference_dsnShtPlotShapeBatchPrint 

This setting causes the print program to search 
both the active and referenced files for plot-
shapes on level dsnShtPlotShapeBatchPrint  

 
Active_dsnShtPlotShapeBatchPrint  (This is the 
Default Setting) 

This setting causes the print program to search only the active file for plot-shapes on level 
dsnShtPlotShapeBatchPrint  

 
Reference_dsnShtPlotShapeBatchPrint 

This setting causes the print program to search only the reference files for the plot-shapes 
on level dsnShtPlotShapeBatchPrint  
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Layout Specifications  
 

Double-clicking the Layout item in the Batch Print dialog 
will produce the Select Layout Specification dialog, as 
shown at the right. 

 
The Maximize to Paper size setting causes the 
MicroStation

 

 Batch Print program to maximize the print 
size to totally utilize the selected paper size.  The pre-
defined plot-shapes in our seed files should normally 
produce accurately scaled PDF print files.  However, 
unique plot-shape sizes, plot settings, margins settings or unexpected printer conditions may 
cause the print scale to be slightly off.  Therefore, the scale of the PDF file prints should be spot-
checked occasionally to confirm final product scale accuracy.     

Display Specifications 
 

Double-clicking the Display item in the Batch Print dialog 
will produce the Select Display Specification dialog, as 
shown at the right. 
 
ApplyLineWeights and Grayscale   (Default Setting) 

This selection overrides the Properties dialog settings 
and forces the line-weights to be toggled ON and the 
color mode to be Grayscale, (as if they had been 
manually set in the Properties dialog, as shown by the 
arrows in the example, below right.)  The Grayscale setting is required to cause attached 
images to be converted to grayscale, (such as photo backgrounds, etc.)  However, 
MicroStation
 

 elements are converted by the print driver selection.   

 
NOTE: The Grayscale setting will 
override any color printer selection and 
cause prints to be created in 
grayscale, not color.  (An example of a 
color printer selection is shown below.)    

 
 
 
 
 
 
 
 
 
 
 
 
ApplyLineWeights and FullColor 

This setting also forces the line-weights to be ON in 
the PDF print file but allows the color to be printed “as 
viewed”, which produces a WYSIWYG print (“What 
You See Is What You Get”).   
 
NOTE:  When full color prints are required, this setting 
should be used with a color printer selection, as shown 
in the example above, left. 
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Select  files and models to print (to PDF file) 
 

After all print specifications have been set, the models to 
be printed must be selected.  This can be accomplished in 
several different ways.  Initially, files may be selected from 
the “Edit” pull-down menu, from either “Add Files” or “Add 
Active File”, as shown at the right.  The “Add Files” option 
allows one or multiple files to be added to the same plot 
list.  It is not required for the active file to be included in the 
list.  (The individual models will be selected later.)   

 
 

 
 

 
 
A second method to add files to the plot list is through the 
Add Design Files icon, as shown at the right. 

 
 

 
 
 
 

 
When either the “Add Files” or “Add Design Files” option 
has been selected, the Select Design files to Add dialog 
will display, as partially shown at the right. 

 
 
 

 
 
 
All models in all selected files will be 
listed in the Batch Print dialog, shown 
at the right.  Click on (select) only those 
models to be printed. 

 
 

 
NOTE:  If printing multiple sheets 
from the Working model, the 
BatchPrintShapePlacement 
program should be run to copy the 
appropriate plot-shape borders to 
the active Working model.   
 
For information on the 
BatchPrintShapePlacement 
program, see instruction file  
21A-80. 
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Saving a “Job Set File” print listing 
 

It is not necessary to remove the unwanted, (and non-highlighted), models from the print list for a 
one-time print job.  However, the list can be saved, (if desired), as a print Job Set File listing for 
future access.  Therefore, if saving the Job Set File listing, it is recommended to then remove the 
unnecessary models from the list before saving.  The Job Set File is saved from the “File > Save” 
pull-down, as shown below. 
 

   
 

After Save or Save As has been selected, the Save Job Set File dialog appears, as shown below. 
Select the location, (red arrow), for saving the Job Set File and provide the file name, (blue arrow).  
The automatic file name extension that is assigned to the saved Job Set File will be “.job”. 
  

 
 

 
The saved Job Set File can be recalled at any time from the 
Batch Print dialog “File > Open” pull-down, as shown at the 
right.  
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After selecting the desired Job Set File, the Batch 
Print dialog will populate with the saved model listing 
and will display the Job Set File name in the title bar, 
as shown at the right, (Example: DandEsheets.job). 

 
NOTE:  To cause a file to automatically retain all 
level settings, (and other settings), the 
MicroStation

 

 User Preference Save Settings on 
Exit can be toggled on, (checked ), so the level 
settings are saved each time a file is closed, and 
therefore the settings will be correct when the file 
is reopened.   This will eliminate the need to open 
a file, change the settings, and then manually save 
the settings before printing.   

The MicroStation

 

 Save Settings on Exit option is found 
under “Workspace > Preferences > Operation”, as 
shown at the right. 

 
 
 
 
 
Batch Printing to the PDF file - creating the PDF 
 

If all models in the Batch Print list are to be printed, there is no 
need to select, (highlight), the model names.  If only some of the 
models in the list are to be printed, they must be selected.   
 
Select “File > Print”, as shown at the right. 

 
 

 
 
 
 
When the Print Batch dialog opens, the default values 
should be as shown at the right.  The value set for the 
MS_PLTFILES variable should cause both the Log file and 
the pdf file to be placed in the home directory of the open 
file.  Use the Browse feature to either confirm or change 
the default values.  Edit the log and the pdf file names, as 
neccessary. 
 
If no specific models were selected in the Batch Print 
dialog model listing, (shown on a previous page), the Print 
Range option, in the Print Batch dialog, (at right), will 
default to ALL.  If specific models were chosen, the Print 
Range will default to Selection. 

 
The Log File, (listed in the Print Batch dialog, above), will provide information about the plot 
creation.  If a new Log File is necessary for each Batch Print run, the Clear Log file Before Printing 
check-box, ( ), should be checked. Otherwise, the new Log information will be appended to an 
existing Log File, if one exists at that location with the same name. 
 
Click the OK button to dismiss the Print Batch dialog and to initiate the creation of the PDF Print file. 
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Printing the PDF file 

 
After the PDF files have been created, they can be sent to any 
printer to produce a paper print.  Double-click the PDF file 
name in Windows Explorer to open the file in Adobe Reader. 
Select File > Print, as shown at the right. 
 

 
 

 
 
 
 
 
 
 
 
When a PDF file print is requested, the size often defaults to 8.5” x 11” paper size, as shown below 
by the red arrow.  The paper size can be changed to 11” x 17”, (or any other size), by selecting the 
Properties button, as shown by the green arrow.  Also, Page Scaling should be changed to None, 
shown by the blue arrow. 

 
To change the paper size, click the Properties button. 
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The appearance of the Document 
Properties dialog depends on the printer 
selection.  For the “DsnOdacColor” printer 
and most Black & White Design Section 
printers, the paper size is selected from the 
Paper/Quality tab, as shown at the right. 

 
 

 
 
For the “DsnOdacBW” printer, the paper 
size is selected from the Paper tab, shown 
by the green arrow at the right.  Select the 
desired paper size, as shown by the blue 
arrow.  Click the OK button to return to the 
Print dialog. 

 
 

The Properties dialog for the scroll 
printer/plotters is different yet, and new 
printers may be different than any shown 
here.  Just continue to open tabs until the 
area to select or enter the correct paper size 
is found. 

 
 
 
 
 
 
 
 
 
 
In the Print dialog, note the Preview: 
Composite paper size, (shown by the red 
arrow, at the right), has changed to the same 
selection made in the Properties dialog, (11 x 
17 in this example).  Occasionally you will have 
to click he properties button a second time to get 
the paper size to change.  

 
 
 
 
 
 
Select the appropriate Print Range, (pages to 
print), shown by the blue arrow, and click the 
OK button to produce the paper prints. 
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Setting Special Print specifications 
 
The Batch Print options listed above should cover nearly every “sheet batch printing” situation for the 
Office of Design.  Even though additional details are likely unnecessary, the following information is 
provided for a more generic description of the MicroStation

 
 Batch Print program. 

Specifications > Manage  
 

Clicking the Batch Print Specifications > Manage 
option, (shown at the right), will produce the  
Batch Print Specification Manager dialog, shown 
below.   

 
 
 
 
 
 
 
The same four options exist in the 
“Types” field as shown previously, 
(as highlighted in yellow at the 
right), but additional options 
become available, including the 
Properties button, located by the 
red arrow. 
 
 
 
 
Printer > …Plot type > Properties 

 
Select “Printer > Plot type > 
Properties”, (as shown by the 
arrows at the right), to produce 
the …Plots Properties dialog. 

 
 

 
 
 
 
 
 
The options in the …Plots 
Properties dialog are as shown 
at the right.  The standard Printer 
Drivers are located as follows:  

 
W:\Highway\Design\CADD\MicroStation\PlotDrivers_PenTables\ 
 
The most common print request will utilize 11x17 Paper Size, Landscape for sheet 
Orientation and will cause multiple sheets to print to a single file.  If it is not the intent to have 
“multiple sheets per file”, click the check-box, (), for “Print document set to single file”.  
Click the Browse button to rename or relocate the output file. 
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Print Area > …dsnShtPlotShapeBatchPrint > Properties 
 

Select “Print Area > print shape 
type > Properties” (as shown by 
the arrows at the right), to produce 
the Print Properties dialog.  

 
The Print Properties options are 
shown at the right.  Select the 
View that will be used to search 
for the Print Boundry, (plot-
shape).  Set the plot-shape 
parameters for the Print 
Boundry.  The Search Files 
check box () options allow for 
searching for the plot-shape(s) in 
the Master file, Reference files, or 
both. 

 
Printing from a Working model 

If printing from the “Working” model, (rather than from individual sheet models), the 
program called Batch Print Shape Placement must be used to copy the appropriate 
referenced “Print Shape Borders” from the reference level, dsnShtPlotShapeMultiColor, 
to the active level, dsnShtPlotShapeBatchPrint.  (For additional information on using 
the Batch Print Shape Placement tool to copy the plot-shapes to the Working model, 
see instruction file 21A-80 ).  After copying the plot-borders from the multi-colored level to 
the batch-print level, they become active dark blue plot-shapes.  Since the plot-shapes 
are now active, the selected Search Files check-box should be for the Master File.  The 
Process Multiple Boundary Elements check-box should also be checked, (). 

 
Printing from an individual “Sheet model” 

The types of files using single-sheet models include Plan, Profile, and Plan & Profile.  
The referenced plot-shape border should be copied to the active file, for each sheet 
model.   A program used to alter the update priority of the Plan Sheet Border will also 
copy the plot-shape to the active file in each model containing a single sheet.  This 
program is called “Border (Send to Back)/(Copy Print Border)”.   (For more information 
on the “…Send to the Back…” program, see instruction file 21A-81 .)  Since the plot-
shapes are now active, the selected Search Files check-box should be for the Master 
File.   
 
NOTE:  When plotting from a “sheet model”, if the Search File check-box options for 
both the “Master File” and “References” are checked, (), , two plots will be 
unnecessarily created for each sheet. 

 
NOTE:  If the Batch Print request combines sheets from file(s) with single-sheet models 
and file(s) with a multiple-sheet Working Model, the “Process Multiple Boundary 
Elements” check-box should be checked, ().   

 
 

NOTE - (For information only):  In Road Design, the only MicroStation model type that 
we use for everything is what MicroStation refers to as a “Design Model”.  We use this 
one model type as a “Design” Model and as a “Sheet” Model.  Our definition of a “Sheet 
Model” is “a model containing only one sheet, developed for the sole purpose of printing”.  
We do NOT use the MicroStation “Sheet Model”, (as defined by MicroStation

 

), which 
refers to a sheet model as one with a white background, and is defined as “The electronic 
drawing sheet”. 
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View 1 is selected as the Reference View (print view), (see at the 
right and the dialog above), because View 1 is normally the only view 
that is rotated correctly during the Geopak

 

 Plan & Profile sheeting 
process.  

  
NOTE: The only view in the P&P Sheet File that is rotated correctly is the one that 
matches the active view in the primary Motif file.  The Motif “active” view is the view that 
was active when the Motif was closed.  The “primary” Motif file would be the “PLN” Motif 
for a Plan & Profile sheet or Full Plan sheet, and the “PRF” Motif for a full Profile sheet. 

 
There is no need to turn on the weight display in View 1 for plotting purposes.  Weights will 
be covered in an upcoming dialog. 

 
Shape - The Print Boundary Shape 
method, (as shown by the blue arrow, 
right), on Level 
dsnShtPlotShapeBatchPrint, refers to 
the blue non-printable PDF plot border, 
(as shown by the red arrow at the right). 
 
The dsnShtPlotShapeBatchPrint level display should be ON in View 1 of each model. 
 
       

Layout > …paper size  > Properties 
 

Select “Layout > …paper size > Properties”, (as shown by the arrows at the right), to 
produce the …Paper size 
Properties dialog. 
 
Settings should normally be as 
shown, including: 

Maximize for Print Size, and 
Center for the Print Origin.   

The value in the Units field makes 
no difference when Maximize has 
been selected as the Print Size. 
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Display > weights and color > Properties 
 

Select “Display > weights and color specifications > Properties”, (as shown by the three 
purple arrows below), to produce the …weights and color Properties dialog. 
 

 
 
 

The Design Pen Table, (blue arrow), is located as follows: 
 

W:\Highway\Design\CADD\MicroStation\PlotDrivers_PenTables\Design.tbl 
 

NOTE:  The toggle settings in the “Display > weights and color specifications > 
Properties” dialog will override the “on-screen” values displayed in the graphics file.  
Toggling “Line Weights ON”, (red arrow), is how View 1 can be used for printing, without 
turning the display weights on in the file.  Change the other settings as appropriate for 
each situation. 
 
NOTE: The Grayscale setting, (green arrow), will override any color printer selection and 
cause prints to be created in grayscale, not color. 

 
Click the OK button to dismiss the “Display > weights and color specifications > Properties” 
dialog.  Click the red “X” to dismiss the Batch Print Specification Manager dialog. 
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